Problema en el BGP

Hola, Como estas?

Ayer por la noche tuvimos un problema con una migración, me llamaron, y dos routers no puede establecer colectividad por BGP.

Solucionado el problema.

Como es uno de los nuevos temas de la prueba, creí que seria interesante traer para usted, asi puedes analizar el error.

No es nada muy complejo.

Los dos routers que acá llamo de router A y B, tiene las interfaces configuradas con las IPs:

Router A – 172.126.125.107

Router B – 172.126.125.97

Las estructura física esta armada como visto en la imagem.

Problema en el BGP

Ahora vamos a las configuraciones de BGP.

ROUTER A

router bgp 65400

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

network 10.1.0.0 mask 255.255.0.0

network 192.168.0.0 mask 255.255.0.0

network 172.140.0.0

network 172.141.7.0 mask 255.255.255.0

network 194.111.22.0 mask 255.255.255.192

neighbor 172.126.125.97 remote-as 65060

neighbor 172.126.125.97 description eBGP to ROUTER_MPLS_1

neighbor 172.126.125.97 soft-reconfiguration inbound

neighbor 172.126.125.97 route-map VzB-BGP-IN in

neighbor 172.126.125.97 route-map VzB-BGP-OUT out

 

ROUTER B

router bgp 65097

no synchronization

bgp log-neighbor-changes

network 172.126.125.96 mask 255.255.255.224

redistribute connected

redistribute static

neighbor 172.126.125.98 remote-as 65097

neighbor 172.126.125.98 description IBGP_to_Arcos-ATS-BKP-MPLS

neighbor 172.126.125.98 soft-reconfiguration inbound

neighbor 172.126.125.106 remote-as 65400

neighbor 172.126.125.106 description IBGP_to_R01

neighbor 172.126.125.106 soft-reconfiguration inbound

neighbor 172.126.125.106 prefix-list RED_MPLS out

neighbor 172.126.125.106 route-map SET_LP_PRI in

neighbor 172.126.125.107 remote-as 65400

neighbor 172.126.125.107 description IBGP_to_R02

neighbor 172.126.125.107 soft-reconfiguration inbound

neighbor 172.126.125.107 prefix-list RED_MPLS out

neighbor 172.126.125.107 route-map SET_LP_BKP in

neighbor 172.126.125.153 remote-as 64549

no auto-summary

Adelanto que hay dos maneras de solucionar el problema del BGP.

Aguardo sus comentários con las soluciones.

Comments

comments